[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#572158: live-helper: Allow installation of i386 debs with amd64 images

Package: live-helper
Version: 2.0~a8-1
Severity: wishlist


we are using live-helper as disaster recovery CD and update CD for firmwares
delivered by HP.
All the HP firmware updates (also the HP RAID maintenance tools like hpacucli)
need the deprecated libstdc++2.10-glibc2.2_2.95.4-27_i386.deb library to work.

Installing this package from etch work on both systems, lenny and squeeze for
the updates.. Anyway we have to include it with our recovery CDs.

In the live helper faq there is described, how to add my own deb's to the
live-cd (copying it to the specific chroot folder), that is working, if the
deb == build-arch.

Anyway I tried to build an amd64 image with libstdc++2.10-glibc2.2_2.95.4-27_i386.deb,
but live-helper ignores this deb file, because i386 != amd64 (without any

I would wish, that live-helper is also able to add i386 debs to amd64 builds.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: