[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Startx in chroot after lh bootstrap && lh chroot

Hello all:

    Time ago I prepared a debien live using lenny. After execute lh_bootstrap && lh_chroot, and before build the squashfs, in order to do some  changes in the live system and prepare the Gnome Desktop with my preferences, I ran startx into after chroot in the live system. In order to be able to do that, I mount with --bind option /sys , /dev and /proc folder.

I mean, I executed lh_bootstrap && lh_chroot in the folder /mnt/debianlive

After that, I did:

cd /mnt/debianlive
mount --bind /dev chroot/dev
mount --bind /sys chroot/sys
mount --bind /proc chroot/proc

startx : --1

After that, the Gnome desktop startx and I could change all I wanted and this changes remain in the debian live system when I did lh_build

Now I'm trying to do the same, but using squeeze. The first thing I have realize is that I must use the new version of live-helper changing the apt sources to squeeze (as I'm running a lenny distribution)  But when I do that, I get the following error:

xauth:  error in locking authority file
xauth:  error in locking authority file
xauth:  error in locking authority file
xauth:  error in locking authority file
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

Please consult the The X.Org Foundation support      at http://wiki.x.org
for help. Please also check the log file at "/var/log/Xorg.0.log" for additional information.

xinit:  Server error.
xauth:  error in locking authority file

Following some suggestions, I have tried mounting /var and /tmp with --bind option, but it doesn't work neither.

Can someone help me with this point?

Thank you very much in advance and sorry for my english (I'm spanish) :-p

Reply to: