[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Live mount problem


I'm having a problem mounting a partition during the 10adduser script (live-bottom) execution.  It just says "Invalid Argument".  I've got a data partition that has already has been formatted with an ext3 filesystem.  In the rest of the script it does the rest of the work relative to a root directory so I made my calls the same.   The script has:
if [ "${BOOTOPTION}" == "Yes" ]; then
   mkdir /root/data
   mount /dev/sda1 /root/data

That's what gives me the invalid argument.
The whole point of what I'd like to do is have sort of a modular setup.  I want to be able to have a tarball of a bunch of apps and configs that the particular kiosk will need, and the live cd will be setup expecting to untar the data and link them etc.  One of the things I'm trying to link is the /etc/shadow and /etc/passwd.  So in essence the end user will be give a cd with the live binary stuff etc and a data tarball then on startup the scripts will mount the data partition, soft link passwd and shadow (and some other stuff) in order to have sort of persistence with the password changes.  We don't want all the kiosks having the same credentials.
So any help with the above problem would be great, and if anybody has tried and succeeded (or failed) at linking the passwd and shadow files at boot time please let me know what worked and doesn't work etc.

~ Scott


Reply to: