[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with most recent live-scripts

Hello all,
  I'm running Debian Sid on my workstation, and used it to build a
Lenny image-on-USB stick for my laptop.  I had the whole setup working
for a while, but several packages weren't included that I wanted to
have all the time, so I rebuilt the image.  First I ran "lh_clean",
since I remembered having problems with building on top of a
previously built image, then lh_config:

lh_config -b usb-hdd --bootloader syslinux --initramfs live-initramfs
--packages-lists kde-desktop --packages "less kile wireshark kismet
mplayer perl-doc scm hugs ruby1.8 audacious python2.5 iceweasel
texlive-latex-base xdebconfigurator lynx w32codecs openssh-server
dnsutils libcurl4-gnutls-dev libglut3-dev rsync ltrace strace"

When I wrote this image to flash and booted from it, it dropped me to
a Busybox shell with no helpful debug messages.  I examined /live.log:

Begin: Running /scripts/live-premount ...
Begin: Adding live session user... ...
debug: Can not mount backdev /dev/loop0 (image = /live/image/live/filesystem.squ
ashfs) on croot/imagename //filesystem.squashfs
mount: Mounting unionfs on /root failed: No such device
unionfs mount failed

... which is not so good.  I started from the top, but ran "lh_clean
purge" first on the theory that some package might have got out of
sync and broken things.  That meant I had to download packages again
from scratch.  However, once it finished, it gave the same error and
the same symptoms.

Any ideas what could cause this?  I've got some files in the
config/chroot_local-includes directory, but nothing has changed there
since the last time I built.  I'm running version 1.0~a31-1 of
live-helper, and retrieved the packages for Lenny just an hour ago or

Help appreciated.


Reply to: