[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Custom Kernel

I am having an issue with booting from a DebianLive CD that has a  
custom kernel.  I created a kernel package using make-kpkg --initrd  
kernel_image.  kernel version is I put the package in  
chroot_local-packages and it installs just fine.  The initrd.img is  
updated fine as well.  I used GRUB as the boot loader.  I have also  
tried syslinux.

When I boot from the CD I get the GRUB kernel selection screen.  I  
choose "live" and it show the proper kernel and initrd image.  It  
continues on and detects hardware etc.  It starts to mount the root  
file system "Begin: Mounting root file system... ..." and then gives  
me the message "end_request: I/O error, dev fd0, sector 0" and dumps  
me to the busybox prompt and says

/bin/sh: cant access tty; job control turned off

I have tried to add the root=/dev/ram or root=/dev/ram0 to the boot  
params but this did not seem to work.

I used "plain" instead of "squashfs" in cconfig/chroot file. I did  
patch the kernel for squashfs in case I wanted to use it.  Was there  
a patch for unionfs that I should have applied?

At the busybox promot I cat the casper.log.  Here are the contents...

Begin: Running /scripts/casper-premount
/init: /init: 152 cannot open /dev/fd0: No such device or address
mount: Mounting unionfs on /root failed: No such device
Unionfs mount failed

Any ideas why it cant find the root filesystem?

Thanks in advance for you help.

Joe Ruddy

Reply to: