[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SCM] Debian package checker branch, master, updated. 2.5.12-80-g6550f02



The following commit has been merged in the master branch:
commit 6550f02ced2b6d71460e2f54358419defce9e8d7
Author: Niels Thykier <niels@thykier.net>
Date:   Sat May 18 13:39:55 2013 +0200

    L::Unpacker: Try to rename the child processes
    
    If supported, have Perl rename the collecting processes that uses the
    the "perl-coll" call interface.  This makes easier to see what is
    happening in (e.g.) top or via ps.  For platforms, where the process
    cannot be renamed, these processes will still be named "lintian" like
    their parent.
    
    Signed-off-by: Niels Thykier <niels@thykier.net>

diff --git a/debian/changelog b/debian/changelog
index 2177bd3..a6fb748 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -89,6 +89,13 @@ lintian (2.5.13) UNRELEASED; urgency=low
     + [NT] Accept Lintian::Path objects to unpacked and control.
   * lib/Lintian/Path.pm:
     + [NT] Rename link_resolved to link_normalized.
+  * lib/Lintian/Unpacker.pm:
+    + [NT] On platform that support it, change the "name" of the
+      process running the collection.  This makes it easier to
+      see what collections are currently being run (like in the
+      versions prior to 2.5.12).  For platforms, where it is
+      not possible to change the name of a running process, the
+      unpack jobs will simply be named "lintian" like its parent.
   * lib/Lintian/Util.pm:
     + [NT] Fix a race condition in touch_file.
     + [NT] Add sanity check in perm2oct for bad permission
diff --git a/lib/Lintian/Unpacker.pm b/lib/Lintian/Unpacker.pm
index e63f1f9..d851727 100644
--- a/lib/Lintian/Unpacker.pm
+++ b/lib/Lintian/Unpacker.pm
@@ -440,6 +440,13 @@ sub process_tasks {
                     my $ret = 0;
                     if ($cs->interface ne 'exec') {
                         # With a non-exec interface, let L::CollScript handle it
+
+                        # For platforms that support it, try to change our name to
+                        # the collection being run (like how it would be with the
+                        # exec case below).  For platforms that do not support,
+                        # the child process will just keep its name as "lintian".
+                        $0 = $coll;
+
                         eval {
                             $cs->collect ($pkg_name, $pkg_type, $base);
                         };

-- 
Debian package checker


Reply to: