[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#537608: complains about missing-build-dependency-for-dh_-command although said command not used

Rene Engelhard <rene@debian.org> writes:

> [ this time important, because of the upcoming "rejection on lintian
> errors" thing. ]

You have gotten false information from somewhere.  No such thing is
happening or proposed so far as I know.

> $ lintian -o openoffice.org_3.1.1~ooo310m15-1.dsc
> [...]
> E: openoffice.org source: missing-build-dependency-for-dh_-command dh_pysupport=python-support
> No.
> [...]
> [...]


I think Lintian has no hope of ever being able to figure that out and an
override is appropriate here.  The level of makefile parsing required to
understand what the package to do is not really feasible, IMO.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: