[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#522613: lintian: false positive package-lacks-versioned-build-depends-on-debhelper 6 (5.0.44 is new enough)

On Sun, 2009-04-05 at 11:58 +0200, Jonas Smedegaard wrote:
> Lintian reports problems with debhelper dependency when using "6" in
> compat and build-depending on debhelper version 5.0.44.
> Debhelper itself claims support for compat version 6 in its changelog
> entry for version 5.0.44, which is the reason this version was used in
> CDBS dependency resolving.

The changelog for 5.0.44 says "introducing beginning of v6 mode" which
is somewhat weaker than "support for compat version 6" imo.

v6 mode was not finalised until the release of debhelper 6.0.0, as is
the custom with debhelper versioning, so I believe Lintian is correct
here.  Depending on debhelper 5.0.44 will give you some v6
functionality, but by no means all of it.



Reply to: