[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#380286: marked as done (bogus missing-dh_python-build-dependency error with arch-specific build-deps)

Your message dated Sat, 18 Nov 2006 17:32:15 -0800
with message-id <E1GlbXb-00056R-7R@spohr.debian.org>
and subject line Bug#380286: fixed in lintian 1.23.26
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: lintian
Version: 1.23.22
Severity: normal


$ lintian -i openoffice.org_2.0.3-4.dsc
E: openoffice.org source: missing-dh_python-build-dependency python | python-dev | python-all-dev
N:   The package runs dh_python in debian/rules but doesn't build-depend on
N:   python or python-dev. dh_python requires /usr/bin/python to run, so
N:   packages using dh_python must build-depend on python (or python-dev or
N:   python-all-dev, which in turn depend on python), even if they don't
N:   otherwise need Python to build.
N:   Refer to the dh_python(1) manual page for details.

wrong, because:

Build-Depends: [...] python-central (>= 0.4.10) [i386 powerpc sparc], debhelper (>=, python (>= 2.3.5-7) [i386 powerpc sparc], python-dev [i386 powerpc sparc] [...]

As wee see, both python and python-dev is there. (and dh_python is only
ran on i386, powerpc, sparc because the python package is only built
there - but lintian of course cannot know it).

But it imho should omit the warning because it's specified....

I'll override in the meanwhile....



-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-1-powerpc
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages lintian depends on:
ii  binutils                 2.17-2          The GNU assembler, linker and bina
ii  diffstat                 1.43-1          produces graph of changes introduc
ii  dpkg-dev                 1.13.22         package building tools for Debian
ii  file                     4.17-2          Determines file type using "magic"
ii  gettext                  0.14.6-1        GNU Internationalization utilities
ii  intltool-debian          0.35.0+20060710 Help i18n of RFC822 compliant conf
ii  libparse-debianchangelog 1.0-1           parse Debian changelogs and output
ii  man-db                   2.4.3-3         The on-line manual pager
ii  perl [libdigest-md5-perl 5.8.8-6         Larry Wall's Practical Extraction 

lintian recommends no packages.

-- no debconf information

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
Source: lintian
Source-Version: 1.23.26

We believe that the bug you reported is fixed in the latest version of
lintian, which is due to be installed in the Debian FTP archive:

  to pool/main/l/lintian/lintian_1.23.26.dsc
  to pool/main/l/lintian/lintian_1.23.26.tar.gz
  to pool/main/l/lintian/lintian_1.23.26_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 380286@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Russ Allbery <rra@debian.org> (supplier of updated lintian package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 18 Nov 2006 17:21:22 -0800
Source: lintian
Binary: lintian
Architecture: source all
Version: 1.23.26
Distribution: unstable
Urgency: low
Maintainer: Debian Lintian Maintainers <lintian-maint@debian.org>
Changed-By: Russ Allbery <rra@debian.org>
 lintian    - Debian package checker
Closes: 97502 133027 189656 190897 289723 322244 332770 360227 380286 387360 389070 393975 394104 394419 394720 395028 395468 396278 398670 399245
 lintian (1.23.26) unstable; urgency=low
   * checks/binaries{.desc,}:
     + [RA] Add a policy reference for unstripped-binary-or-object.
       Thanks, Bas Wijnen.  (Closes: #394419)
     + [RA] Add a special exception to the shared library dependency check
       for the dynamic loader itself.
   * checks/changelog-file.desc:
     + [RA] Downgrade to a warning several errors with changelog files,
       including compression and a text version of HTML changelogs, that
       are only shoulds in Policy.  (Closes: #289723)
     + [RA] Cleaned up language and use of unbalanced single quotes in
       numerous descriptions.
   * checks/control-file{.desc,}:
     + [RA] Diagnose a control file that creates binary packages in a
       different archive category from the source package or the other
       binary packages.  Idea from Yann Dirson.  (Closes: #394720)
     + [RA] Close opened files.
     + [RA] Add info-level check for Section in the source section of the
       control file.  (Closes: #322244)
   * checks/cruft{.desc,}:
     + [RA] Tighten the timestamp check on config.{sub,guess} to look for
       files dated 2004 or newer, since that's when x86_64 was added.
       Increase to an error at the request of Ryan Murray since we already
       suppress this warning of config.{guess,sub} are modified by the
       Debian patch or if the package build-depends on autotools-dev.
       (Closes: #190897)
   * checks/debconf{.desc,}:
     + [RA] Take into account comma escaping when checking the number of
       translated choices.  Reported by Frans Pop.  (Closes: #395028)
     + [RA] Only require debconf be loaded in the postinst script if a
       config script exists.  Reported by Josselin Mouette.
     + [RA] Require pre-depends on debconf if debconf is used in the
       preinst script.  Update the long description to deprecate only
       depending on debconf and falling back on another configuration
       system.  Reported by Josselin Mouette.  (Closes: #395468)
     + [RA] Warn of debconf notes displayed with low or medium priority,
       with an exception for Policy-required device file warnings.  Based
       on a patch by Thomas Huriaux.  (Closes: #389070)
     + [RA] Close files after opening them, fixing incorrect line numbers
       when reporting problems with config scripts.
   * checks/debdiff{.desc,}:
     + [RA] Check for creation of ~ and .xxx.swp backup files in the Debian
       diff, but only at the info level for now since they cause no harm.
       (Closes: #332770)
   * checks/fields{.desc,}:
     + [RA] Clarify in missing-build-dependency why lintian does not take
       into account transitive build dependencies.  (Closes: #393975)
     + [RA] Avoid Perl warning when diagnosing a Python-Version of the form
       "all, >= 2.4".  Thanks, Thijs Kinkhorst.  (Closes: #394104)
     + [RA] Teach the debian/rules parsing about make conditionals and
       don't require build dependencies for lines encountered inside a
       conditional (in other words, assume people using conditionals know
       what they're doing).  Fixes a false positive due to the unusual
       arch-specific build dependencies for openoffice.org, reported by
       Rene Engelhard.  (Closes: #380286)
   * checks/files{.desc,}:
     + [RA] Check for vim .swp files in the package.
     + [RA] Split the warning for NFS temporary files into a separate tag
       from the warning for editor backup files.
   * checks/infofiles:
     + [RA] Close opened files.
     + [RA] debhelper no longer adds a --section flag to install-info, so
       don't warn about any install-info invocation without --section.
       Instead, check each info file for INFO-DIR-SECTION and diagnose
       calling install-info without --section if any info file is missing
       this information.  (Closes: #97502, #398670)
     + [RA] Checks for the compression and suffixes of info files were not
       being run due to a mistake in specifying either /usr/info or
       /usr/share/info as an info directory.  Re-enable them.
   * checks/md5sums{.desc,}:
     + [RA] Add a tag for a missing md5sums control file, but only at info
       level, at least for now.  (Closes: #133027)
     + [RA] Do better syntax checking of the md5sums control file and
       report malformed lines as a tag rather than aborting lintian.
     + [RA] Downgrade file-missing-in-md5sums to a warning since it doesn't
       break the package or debsums and may be intentional.
   * checks/menu.desc:
     + [RA] Remove stray commas in Ref strings since the reporting code
       considers commas to be separating two different references.
   * checks/menu-format{.desc,}:
     + [RA] Support the sux, gksu, and kdesu wrappers in menu commands as
       well as su-to-root.  (Closes: #360227)
     + [RA] Fix tag name for menu-icon-cannot-be-parsed.  Thanks, Bill
       Allombert.  (Closes: #399245)
   * checks/po-debconf{.desc,}:
     + [RA] Check for misnamed PO files in debian/po, which cause
       translations to be merged into the template with the wrong names and
       not found.  Based on a patch by Thomas Huriaux.  (Closes: #387360)
   * checks/shared-libs:
     + [RA] Calling ldconfig is also required for libraries installed in
       various subdirectories of its standard search path based on hardware
       capabilities.  Reported by Aurelien Jarno.  (Closes: #396278)
   * debian/rules:
     + [RA] Exclude testset/diffs/binary.c~ from dh_clean.
   * frontend/lintian:
     + [RA] Add --fail-on-warning option to exit with non-zero status if
       any warnings were found.  Thanks, Daniel Bonniot.  (Closes: #189656)
   * man/lintian.1:
     + [RA] Document --fail-on-warning.
 cda4e08aaf178b646cc6ce23bc1c30a0 803 devel optional lintian_1.23.26.dsc
 15742add8a98724dc3aba2357db88ce9 322262 devel optional lintian_1.23.26.tar.gz
 d87b2eee380fc9c8670ca44a69af93e0 273294 devel optional lintian_1.23.26_all.deb

Version: GnuPG v1.4.5 (GNU/Linux)


--- End Message ---

Reply to: