[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compatibility of GPLv2 and Apache v2 (OpenSSL again)



On Sat, Dec 8, 2018 at 2:53 AM Sebastian Andrzej Siewior wrote:
> On December 7, 2018 6:34:39 PM UTC, Francesco Poli wrote:
> >
> >It was a long ongoing process.
> >The news is that it seems to have finally come to an end...

This appears to be the commit where it happened:

https://github.com/openssl/openssl/commit/151333164ece49fdba3fe5c4bbdc3333cd9ae66d

Subsequent commits changed mention of the license in various locations.

> Yes. It is okay for "GPLv2 or later" but I'm curious if it is still okay for GPLv2 only projects with the exception I mentioned to link against libssl once it is Apache v2 licensed.

It depends on the wording of the particular exception used, but IIRC
the standard one allows linking with OpenSSL regardless of license.

-- 
bye,
pabs

https://wiki.debian.org/PaulWise
http://bonedaddy.net/pabs3/


Reply to: