[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Applications linking against GPLv2 only libqt3/libqt4 and [L]GPLv3+ libraries

With the last version updates both libgsl0ldbl and libgmp3c2 became
GPLv3+ respective LGPLv3+.  But there exist numerous applications
linking against one of these libraries, simultaneously linking against
one of the Qt libraries which are GPLv2 only and despite having numerous
linking exceptions, the GPLv3 variants are not amongst them.

There seems to be no precaution mechanism against such problems in the
archive - and from a simple minds point of view such a problem makes
the binary non-distributable (or does a problem only exist on the
users machine who is doing the runtime linking?).


Reply to: