[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GPL v3 app with copied GPLv2 or later source and linked against LGPL-2 or later libraries




"Neil Williams" <codehelp@debian.org> wrote in message 20070710115359.4cff03e6.codehelp@debian.org">news:20070710115359.4cff03e6.codehelp@debian.org...

All the gnucash source code used in gpe-cash is "GPLv2 or later".
The Gtk frontend for gpe-cash is GPLv3 or later. I am therefore
using my option to distribute and modify the gnucash source code
under a later version of the GPL, bringing the entire source code
for gpe-cash under version 3 of the GPL. This specifically includes
the shared library libqofcashobjects.
Neil Williams <codehelp@debian.org>

libgpewidget, GPE and gpe-cash:
===============================
libgpewidget is licensed under the Lesser GPL v2 or later, like most
gpe libraries. gpe-cash under the GPLv3 can be linked against these
libraries.
See http://gplv3.fsf.org/dd3-faq

Have I got that right?

As far as the legality and licence compatibility, everything looks fine.
As for what is going into the copyright file, I have no comment. Somebody more
familiar with that than me should address that.

IANAL, IANADD



Reply to: