[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: LGPL v3 compatibilty



On Sun, 1 Jul 2007 13:58:08 +0200 Andreas Metzler wrote:

[...]
> LGPLv3 libraries
> could not be used in GPLv2-only programs.

I'm afraid that this incompatibility is still true.

AFAIUI, when you redistribute a GPLv2-only program in compiled form, the
GPLv2 insists that the libraries the program links with (excluding
system libraries...) are available under GPLv2.

But an LGPLv3-only or LGPLv3-or-later library is available under GPLv3,
not under GPLv2.


All this, assuming that the FSF's legal theory of linking is correct:
this theory has never been tested in court, AFAIK, hence we do not know
if it would hold.  However, we have to assume that it's correct, to be
on the safe side.


Disclaimers: IANAL, TINLA, IANADD.


-- 
 http://frx.netsons.org/doc/nanodocs/testing_workstation_install.html
 Need to read a Debian testing installation walk-through?
..................................................... Francesco Poli .
 GnuPG key fpr == C979 F34B 27CE 5CD8 DC12  31B5 78F4 279B DD6D FCF4

Attachment: pgpyqi3PvBmth.pgp
Description: PGP signature


Reply to: