[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian 11 freezes on Dell Latitude e6520


I have been using Debian on a Dell Latitude e6520 for ten years now.
At present, it runs without problem an up-to-date Debian 10 system.

From the beginning, before upgrading to any new release, I tried its
live image. This strategy has always successfully allowed upgrading
without stress. Sometimes I would do an upgrade, sometimes a clean new
installation. The latter one was the case for Debian 10.

Now, since Debian 11 was released earlier this year, I've been testing
its behaviour on the machine. Unfortunately, even with the latest live
image, including non-free firmware, the test is not passed. The
computer boots well and the graphical interface (I tried my usual
xfce, but also mate) appears neat and working. However, after a few
moments varying from few seconds to no more than a couple of minutes,
the system freezes completely. Impossible to open a console, there is
no answer at all, only physical shutdown is possible.

I have searched for other people having similar problems and found a
forum where someone described the same issue with the Manjaro distro:


Unfortunately, the only advice given is to switch to another
distribution (AntiX is mentioned) I would prefer to stay on Debian, but
it's true that when support and security updates will arrive to an end
for Debian 10, I will need to move anyway to a different distro if this
problem is not solved.

Incidentally, I must say that I'm also unable to run Tails on this
machine since a few releases ago, for what looks as precisely the same

I wonder if this trouble could result from the upgrading of the kernel
to version 5.x? Or from the newest versions of Xorg or the nouveau
driver? By the way, I thought that the non-free nvidia module and not
nouveau would be used in the live images with non-free firmware. 

The only debugging step I have managed to take during the few seconds
where the system is running is capturing in a file, on another USB
stick, the output of:

# sudo dmesg -wH

I have compared it with the results of the same command on my normally
running Debian 10. But my capacities to extract from there any useful
information are too limited. I hesitate to send those longs files to
the list.

Any clues would be welcomed.


-- mol

Attachment: pgpebHcubTTzd.pgp
Description: Firma digital OpenPGP

Reply to: