[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help: Hosed FS on HP nx8420?


On Mon, 30 Jul 2007, Tim Wood wrote:

> I have an HP nx 8420 Core2 Duo T7400, 2GB RAM, SATA 100GB 7400rpm HDD, 
> ATI X1600 graphic card, bought mid February.
> I had great difficulty persuading it to repartition the drive. I 
> installed the network edition of Edgy, bare system, then upgraded to Sid.

if its debian, its "etch"

> The partitions:
> sda1 19.75GB NTFS, sda2 52MB FAT, <sda5 ext3 (now ext2) 15.45GB as /, 
> sda6 15.45GB ext3 /home, sda7 14.71GB Fat32, 16.9GB free, sda8 1.98GB 
> swap> sda4 6.66GB Fat - WinXP installation files.

> When I bought it I did not appreciate that it had an embedded security 
> chip, which I now think the source of my problems.
i can't believe this, nearly every buisness notebook has some tpm chip..
> On a reboot into WinXP a couple of days ago, it wanted to do some 
> updates, so I let it. One of them was for the access to the security 
> chip. I don't clearly remember now but I think I disabled the chip  on 
> the original installation. The update seems to have turned it back on.
> When I installed Linux I used Grub in the MBR and it worked well, 
> handing control to the NT loader, when booting WinXP.
for me its the normal "windows" thing, after some generic updates windows always 
writes to the mbr, because ..
> On rebooting back to Linux after the above update, I was met with Error 
> 13, from Grub, though initially I did not recognise it as coming from Grub.
> I won't try to go through the saga of the following 2 days. I booted 
> Knoppix 5.1 and tried to chroot into sda5 but it came up with errors no 
> matter what I tried.

the error would ne nice to know..

> I had amd64 kernels from 2.6.18/20/21/22 and the 2.6.22-1-686. I got to 
> the point were several would start to boot but all end up with the sequence:
> =========================================================
> Begin: Running /scripts/init
> Done:
> Done:
> Begin: Running /scrips/init-bottom
> Done:
> run-init /sbin/init No such file or directory
> kernel panic - not syncing: Attempted to kill init
> ==========================================================

> An fsck came up with heaps of errors, cross linked files etc.
> My /Home partition shows no errors.
> The basic root partition appears intact with /var/lib/pkgstates and 
> dpkg/status.
> If I could find a way to get it running I could re-install the packages 
> (there's 1.5GB of debs in the archive). An alternative, if I could find 
> a way to extract a list of installed packages, would be to re-install 
> from scratch.
> The machine has the capability of booting off a variety of media (I put 
> the internal HD on the end), but will not boot off my USB stick or USB HD.
> Any advise would be welcome.
> Oh! I did have a backup from March, but somehow managed to "nuke" it:)

if your /home is OK, then just run the debian setup again and format the /
partition. And you want a backup of your /home.

All user related data should be on your home, so it should no big deal to
install the system around a secound time.

Florian Reitmeir

Reply to: