[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Latest ipw2200 driver breaks when used with wpa_supplicant

On Wed, Jun 29, 2005 at 03:30:27PM -0700, Joe Emenaker wrote:
> After upgrading to the 1.0.4 driver (and to the 2.3 firmware) for the 
> ipw2200 in my Dell Inspiron, Kismet finally worked (yea!). However, when 
> I tried to enable WPA by switching from waproamd to wpa_supplicant, my 
> keyboard would lock up and I would see endless messages about "error 
> detected in firmware".
in my case ipw2200 1.0.4 doesn't work properly. I get continuous
disassociations with AP and firmware is crashing and restarting
continuously. So I downgraded to the more stable 1.0.3 sarge ipw2200
module that works ok except that it doesn't work with wpa_supplicant
from sarge (3.8). The solution is: ipw2200 1.0.3 from sarge and
wpasupplicant 4.2.1 from etch/sid. All work fine (suspend, hardware
switch management, ecc.).

Leonardo Canducci 
GPG Key ID: 429683DA

Reply to: