[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge problem

Derek Broughton wrote:
> On Monday 16 May 2005 11:35, Emmanuele Salvati wrote:
>>i reinstalled it, not using grub (as default) but using lilo. it works!!
>>thank you very much for your help.
> That makes sense (of a kind).  Grub lets you move things around, some, but 
> needs you to name the root device correctly - which means it fails if the 
> root device comes up on another controller.  Lilo should be able to reboot if 
> it successfully ran its configuration.

I had the same error message, some time ago. I wanted to migrate a
installation from one disk (old & small) to another disk (newer &
larger). I installed both disk in one machine, the newer disk was
mounted as /dev/hdd. Then I copied the /-partition from the old disk
to the new one, made a chroot to where I mounted the /dev/hdd and
run lilo. Lilo now wrote to the mbr that it should load the kernel
from somewhere on /dev/hdd. Then I installed the new disk alone in
the machine (now as /dev/hda) and bootet - I got the error message,
that started this thread. booting from a CD, running lilo fixed it.

	hope that helps

Reply to: