[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Frozen touchpad after resume

Hi all,

I've come a long way towards getting suspend-to-ram working on a whitebox 
centrino machine with a 855GM chipset and a 2.6.11 kernel. A script from 
David Härdeman has solved the common blank-screen-on-resume issue, using the 
vbetool utility. (I can provide this script to anyone interested.)

However, on resume the touchpad is inoperative. This occurs with both the 
synaptics and the PS2 drivers. 

After resume, /dev/input/event1 - which is assigned to the touchpad 
automatically - has disappeared, as has /dev/input/mouse0. Recreating these 
nodes manually has no effect. 

Also, the entries in /proc/bus/input/devices and /proc/bus/input/handlers 
relating to the touchpad have disappeared.

Restarting X does not fix it; restarting hotplug creates a device ~/input2 
which refers to a PC speaker device (?!), but still no ~/input1.

Rebooting puts it all back to normal.

My questions are: how are the above device nodes and file entries created? Is 
there a possible workaround? Can devices be made permanent? Could this be a 
kernel bug? Etc.

BTW, I use udev and my psmouse support is compiled as a module.


John O'Hagan


Reply to: