[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

New hibernate shows strange behaviour


yesterday I tried to upgrade my Kernel from 2.6.9 to 2.9.10 as well as
hibernate and ipw2100-source.  I had certain trouble with the kernel
which I do not want to discuss in this thread (I just haf fsck errors
which need manual intervention for one partition and later for another
partition - so just remove this beast and have another look AFTER the
upcomming conference events!).

The strange thing is that with my old setup but the new hibernate from
unstable (1.05-1), the SwSusp2 (software-suspend-2.1.5-for-2.6.9) did
not worked as before.

I have:

$ grep -v "^#" /etc/hibernate/hibernate.conf | grep -v "^ *$"
UseSwsusp2 yes
Reboot no
EnableEscape yes
DefaultConsoleLevel 1
SuspendDevice swap:/dev/hda2   ### this setting has no effect
                               ### I have introduced it after observing
                               ### the described problem, but it makes
                               ### no difference
Verbosity 0
LogFile /var/log/hibernate.log
LogVerbosity 1
Distribution debian
SaveClock yes
ChangeGrubMenu yes
GrubMenuFile /boot/grub/menu.lst
AlternateGrubMenuFile /boot/grub/menu-suspended.lst
LockXScreenSaver yes
UnloadBlacklistedModules yes
LoadModules auto

And my /boot/grub/menu-suspended.lst file has the only difference to the
"normal" menu.list that it has a smaller timeout and one entry on top
which says:

title           Resume from Suspend on Disk
root            (hd0,0)
kernel          /vmlinuz root=/dev/hda1 ro vga=791 resume=/dev/hda2

This worked perfectly as intended until the upgrade of hibernate.  If I now
select the "Resume" entry I get:

  Booting  'Resume from Suspend on Disk'

root  (hd0,0)
 Filesystem Type is ext2fs, partition type 0x83
kernel /vmlinuz root=/dev/hda1 ro vga=791 resume=/dev/hda2

Error 15: File not found

Press any key to continue...

If I afterwards select the "normal" Kernel entry (below the "Resume"
entry) the box is in fact RESUMED instead of a normal Boot as I expected.

Any hint what might went wrong here?

Kind regards



Reply to: