[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound structure on a Dell inspiron 8600

I've previously experienced that a sound device is made at /dev/dsp0 or 
something similar. The trick was to symlink /dev/dsp to /dev/dsp0, and 
everything worked. If this is also your problem, this would probably remedy 
it. Otherwise, I have no idea.
By the way: Isn't the MAKEDEV script obsolete with devfs, or am I mistaken?

Hope this helps. Regards, Anders Breindahl.

On Friday 07 January 2005 20:47, Wendy Leigh Vandoolaeghe wrote:
> 2.6.8-1-686 #1 Thu Nov 25 04:34:30 UTC 2004 i686 GNU/Linux
> The sound wasn't working perfectly, so I installed (with wajig) all the 
> alsa modules. and then *hurray* the sound for the cd player, dvd player 
> (totem) and xmms (but only if i choose oss as my output plugin) worked 
> perfectly!
> however, when i restarted the laptop a few days later, nothing worked. 
> /dev/dsp was non-existant, so i copied another dsp file there. but still i 
> can't seem to get any sound. and dsp seems to dissapear every time i 
> reboot.
> user:/# MAKEDEV dsp
> /sbin/MAKEDEV: don't know how to make device "dsp"
> it seems weird. it seems like it is loading the right drivers etc, but 
> still doesn't work. For example. if i run alsaconf, then the card is set 
> up. the modules seem to be loaded and there's no errors. but then, if i try 
> to run amixer for example, it says device not found.

Reply to: