[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cannot get debconf version

Hi list,

I have the following problem:

when I try to install whatever with:

apt-get install ...

i get: Try 'apt-get -f install'
When I try that, I always get:

E: Cannot get debconf version. Is debconf installed?
debconf: apt-extracttemplates failed: Bad file descriptorE: Cannot get
debconf version. Is debconf installed?
Unpacking libc6 (from ...)...
dpkg (subprocess): unable to execute new pre-installed script: No such
file or directory
dpkg: error processing ...... (--unpack):
subprocess pre-installation script returned error exit status 2

I tought that the problem might be in dpkg, so i compiled it from source.
But the error still persist.

In summary in the moment there is no way to install on my system:

libc6, bash,... whatever you can think of.

I have some questions:
1. How and where from I can get the sources of debconf? (with "apt-get
source --tar-only" It is not downloading nothing)
2. Where does apt-get read the debconf version?
3. What is this pre-installed script?

In fact for any idea I will be greatful...

                Thanks in advance,

Reply to: