[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [hp pavilion ze4222] cd writer issue

ale wrote:
Hi everybody,
I'm new to the list and relatively new to debian. I'd been using some debian based distros (knoppix, kanotix, mepis, dsl) for some time and now, finally, I switched to Debian Sarge (kernel 2.6.8-1) thanks to its fantastic net installer.


now I have some problems that I had never experienced with other distros.

First off the cd writer (others will come...)

My cd-rw doesn't work, it can only read cds (with other distros it worked fine save for cleaning cdrw...). I don't understand what the problem is and I don't know where to start from to find a solution, so here I am!

During boot the machine finely detects my cd writer/dvdrom:
but then it only works as reader. I tried cdrecord -scanbus and this is what I got:

# cdrecord -scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling

cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .


# cdrecord dev=ATA: -scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling

scsidev: 'ATA:'
devname: 'ATA'
scsibus: -1 target: -1 lun: -1
Warning: Using badly designed ATAPI via /dev/hd* interface.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
       1,0,0   100) 'QSI     ' 'CDRW/DVD SBW-241' 'VX08' Removable CD-ROM
       1,1,0   101) *
       1,2,0   102) *
       1,3,0   103) *
       1,4,0   104) *
       1,5,0   105) *
       1,6,0   106) *
       1,7,0   107) *

I edited my /etc/default/cdrecord like this (only relevant lines):
# drive name    device    speed    fifosize driveropts
teac=        1,3,0    -1    -1    ""
panasonic=    1,4,0    -1    -1    ""
plextor=    1,4,0    -1    -1    ""
sanyo=        1,4,0    -1    -1    burnfree
yamaha=        1,5,0    -1    -1    ""
cdrom=        0,6,0    2    1m    ""
cdrw=        1,0,0    12    30m

What can I do?


Kernel 2.6.8 have problems with CDRW, see http://www.k3b.org. I suggest you do as I did. Use 2.6.7 til 2.6.9 comes out.

Christian     .-.    Bjälevik
Eskilstuna    /v\    [Sweden]
ICQ UIN      // \\   60036598
Linux User  /(   )\  [344682]
GPG Key ID   ^^-^^   19282112

Reply to: