[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound on Sony GRT170

Hi. Well, it worked under Knoppix, so I'm sure it's just me.

I've just finished wiping and reinstalling Sid on a Vaio PCG-GRT170, 
which has worked before but got messed up with a Xwindows upgrade last 
week. Everything has come back except sound. mpg123 and xmms just hang 
until killed, and the following error is seen in dmesg:

   i810_audio: drain_dac, dma timeout?

I've set the permissions on /dev/dsp and /dev/audio to 777, just to make 
sure that wouldn't be a problem. Also...

i810_audio             24764   0
ac97_codec             13716   0  [i810_audio]
soundcore               3940   2  [i810_audio]

When I cat sound.au > /dev/audio, I get a screech, so it seems that's 
completely out of time sync.

The Sound-HowTo talked about kernel modules, which doesn't seem to be 
the problem here.

Any suggestions? I expect it's a permissions problem that I just don't 


September 11th, 2001
The proudest day for gun control and central 
planning advocates in American history

Reply to: