[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Configuration problem for wireless card with sid

Hi all

I have an Acer Travelmate 520iT laptop and a Belkin wireless card. Untill
it recently it worrked fine. Due to some unforeseen events i had to do a
full reinstall of Debian (unstable) on my machine. After doing this i can
no longer get my Belkin card to work.

Below are some of the particulars on my machine..questions follow

lsmod output is

Module                  Size  Used by    Not tainted
ds                      6624   2
i82365                 22384   2
pcmcia_core            41376   0  [ds i82365]
apm                     9116   2  (autoclean)
orinoco                29568   0  (unused)
hermes                  3296   0  [orinoco]
ac97_codec              9568   0  (unused)
eepro100               17232   1
keybdev                 1664   0  (unused)
usbkbd                  2848   0  (unused)
input                   3040   0  [keybdev usbkbd]
usb-ohci               17472   0  (unused)
usbcore                48000   1  [usbkbd usb-ohci]

Cardctl ident output is

Socket 0:
  product info: "Belkin", "11Mbps Wireless Notebook Network Adapter", "Version 01.02", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)
Socket 1:
  no product info available

my  /etc/network/interfaces configuration file contains the following
(ipadresses have been changed by me)

# The loopback interface
auto lo
iface lo inet loopback

# The first network card - this entry was created during the Debian installation
# (network, broadcast and gateway are optional)
auto eth0
iface eth0 inet static

iface eth1 inet static
	wireless_essid someone
	wireless_mode managed
	wireless_enc [1] XXXXXXXXXXXXXXXXXXX restricted

the command ifup generates the following command

/etc/network/interfaces:17 option with empty value
ifup: couldnt read interfaces file "/etc/network/interfaces"

when the Belkin card is inserted into the slot syslog reports the following;

cardmgr[460]: unsupported card in socket 0
cardmgr[460]:   product info: "Belkin", "11Mbps Wireless Notebook Network Adapter", "Version 01.02", ""
cardmgr[460]:   manfid: 0x0156, 0x0002  function: 6 (network)

My question is simply - whats happening here? Why isnt the card detected
and why cant iwconfig get it to work, and the error report about the
interfaces file is weird. Fact is i have been unable to get any other
interface than eth0 up. No matter what i put in eht1 i cant get the
interface to come up - never mind whether or not is can talk to access
point or not - i cant even get an eth1 device to exist.

I must have done something very very stupid or perhaps there is a
worldwide conspiracy against me (*s*), either way, any help would be


Reply to: