[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCMCIA / Kernel Bothers

Hi Everyone,

	Just joined the list so please go easy on me!

	I've been working around a week so far on and off trying to sole the
	current problem I have, it is thus:

	I am running Debian Woody 2.4.18-bf24 (stock kernel which came with the
	distro). Needing the use of my Wireless card I set about installing a
	Kernel so that I can add in the orinoco patches to enable me to tell my
	wifi card I want to change channels. I downloaded 2.4.18-i686 sources
	from aptitude and went about installing the kernel. I'm pretty well
	versed in such actions so this isn't really a bother. However I've
	never really dabbled with PCMCIA before.

	Anyways, the short story is 2.4.18-bf24 works with PCMCIA fine, and
	2.4.18-i1686 can't start up PCMCIA == it simply can't recognise the
	controller. The controller is on a Toshiba Portege 7000CT with a ToPiC
	97 .

	I've read over all of the documentation at the pcmcia-cs web site and
	read over the particular woes that say that the Topic97 is bothersome,
	but it obviously works on the bf24 kernel, so why not on the new

	Here is a bit of debugging for you:
	 skywalker kernel: Linux Kernel Card Services 3.1.22
	  skywalker kernel:   options:  [pci] [cardbus] [pm]
	   skywalker kernel: Intel PCIC probe: not found.
	    skywalker kernel: ds: no socket drivers loaded!
	(that's on the 2.4.18 -- not working kernel)

	This is the bf-24 kernel:

	kywalker kernel: Linux PCMCIA Card Services 3.1.33
	 skywalker kernel:   kernel build: 2.4.18-bf2.4 #1 Son Apr 14 09:53:28 CEST
  skywalker kernel:   options:  [pci] [cardbus] [apm]
   skywalker kernel: Intel ISA/PCI/CardBus PCIC probe:
    skywalker kernel: PCI: Found IRQ 11 for device 00:0b.0
     skywalker kernel: PCI: Found IRQ 11 for device 00:0b.1
      skywalker kernel:   Toshiba ToPIC97 rev 05 PCI-to-CardBus at slot 00:0b,
      mem 0x10000000
       skywalker kernel:     host opts [0]: [slot 0xd0] [ccr 0x11] [cdr 0x86]
       [rcr 0x02] [pci irq 11] [lat 168/176] [bus 20/20]
	skywalker kernel:     host opts [1]: [slot 0xd0] [ccr 0x21] [cdr 0x86]
	[rcr 0x02] [pci irq 11] [lat 168/176] [bus 21/21]
	 skywalker kernel:     ISA irqs (default) = 3,4,7,10,12,15 PCI status
	  skywalker kernel: cs: memory probe 0x0d0000-0x0dffff: clean.
	   skywalker kernel: cs: IO port probe 0x0100-0x04ff: excluding
	   0x170-0x177 0x220-0x22f 0x2f8-0x2ff 0x330-0x337 0x370-0x37f

	   And so on...

	   I've tried switching the bios to cardbus or pcic rather than auto,
	   but no luck there either, I get PCMCIA to start on the 2.4.18 kernel
	   but it just shows the cards in an un-working state.

	   I also tried the lilo option pci=biosirq

	Does anyone have any ideas? I'd be very very grateful. 


	Alistair Ross
The glances over cocktails That seemed to be so sweet,
Don't seem quite so amorous Over Shredded Wheat  ;)

Alistair J. Ross
IT Consultancy, Internet & Open Source Specialist
Tel: 0702 112 8458 / 0870 748 4346

Reply to: