[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: alsa-source invalid group

On Wed, 23 Jul 2003, Jeff wrote:

> I'm trying to compile the alsa-source in testing and having a
> problem.
> I run ./configure and then make without trouble.  When I run make
> install, I get this error:
> <snip>
> if [ -d /sbin/init.d ]; then \
>   install -m 755 -g  -o  utils/alsasound /sbin/init.d/alsasound; \
> elif [ -d /etc/rc.d/init.d ]; then \
>   install -m 755 -g  -o  utils/alsasound /etc/rc.d/init.d/alsasound; \
> elif [ -d /etc/init.d ]; then \
>   install -m 755 -g  -o  utils/alsasound /etc/init.d/alsasound; \
> fi
> install: invalid group `-o'
> make: *** [install-scripts] Error 1
> root # 
> <snip>
> I have a self-compile 2.4.21 kernel running.
> I can't figure this out, nor can I find anything googling yet.  Anyone
> have an idea on how to get past this?

I ran a "install --help" which told me this relevant line:

-g, --group=GROUP   set group ownership, instead of process' current 

So it would seem that there is an error in your install script. Whoever 
made it forgot to add which group the "alsasound" file should be owned by. 
Personally I would try to get a more stable package. But if you like 
living on the edge you could try to fix it yourself by modifying whichever 
file contained the if-command you quoted above.

If you choose to gamble you should change the install script to do this 

if [ -d /sbin/init.d ]; then \
  install -m 755 -g root -o  utils/alsasound /sbin/init.d/alsasound; \
elif [ -d /etc/rc.d/init.d ]; then \
  install -m 755 -g root -o  utils/alsasound /etc/rc.d/init.d/alsasound; \
elif [ -d /etc/init.d ]; then \
  install -m 755 -g root -o  utils/alsasound /etc/init.d/alsasound; \

Ask someone who have a working alsasound package installed, what group 
ownes the /sbin/init.d/alsasound, /etc/rc.d/init.d/alsasound, or 
/etc/init.d/alsasound file. Also if/when you fix this you should get 
another error. 

.. oh. Never mind the above ;). It seems as if one doesn't have to specify 
a group name after the "-g" parameter. If one had to, you would get two 
error messages. If the -g parameter doesn't need a group name after it for 
the "install" command to work, perhaps the -o parameter doesn't either. If 
that reasoning is correct, we can draw the conclusion that there is 
something else wrong. And that might be:

install --help
-o, --owner=OWNER   set ownership (super-user only)

..that you maybe need to be logged in as root ("super-user") for this to 

Erm.. So what I am rambling about here is that you should try to do what 
you did as root instead. If you already where root and it still didn't 
work, I don't know what you could do to fix the problem.

..oh. But then again I see .. hehe:

> root #  

from your quote.

Which means you ran this as root.

..but then again it said:

> install: invalid group `-o'

It seems to think that "-o" is a name of a group! Therefore one may 
conclude that the -g parameter demands a group-name. And possibly the -o 
parameter demands a name of an owner. 

Soo.. Ask someone with a working alsa installed if they can run these 
commands and tell you their output:

ls -la /sbin/init.d/alsasound 2>/dev/null
ls -la /etc/rc.d/init.d/alsasound 2>/dev/null
ls -la /etc/init.d/alsasound 2>/dev/null

The output should be something like this:

-rwxr-xr-x    1 tommy    root         148 Jul 23 13:01 alsasound

I dont have alsa installed. So the above line is a made up one. But in the 
example above you can see that "tommy" is the owner (-o) and the group 
that owns the file is the "root" group (-g).

Then, you can correct your install script. And if you're nice, you can 
report the error and fix to the developers of alsasound so other users 
wont get the same problem. Or if you're not in any hurry you can just wait 
a couple of hours or days until someone else relalizes the package wont 
install. Then you can dl the fixed package and it will work.

Tommy - http://www.geocities.com/todu5811/autosignature?1121
RFC2440 fingerprint: 4445 BB5E AE67 A0C9 7B25  5715 F938 88CB 7A10 2364

Reply to: