[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: acpi and kernel 2.4.21


On Sun, Jul 13, 2003 at 07:45:24PM +0200, Kai Timmer wrote:
> i want to enable the acpi support for my dell inspiron 8200. So i have
> downloaded the acpi patch und patched the kenrel sources. In the
> patching process i got some messages like "there is allready a patch
> applied". I have ignored them and went further.
> When i'm going to compile the kernel now i get the following error
> message:
> realpath(/usr/src/kernel-source-2.4.21/drivers/acpi/include) failed, No
> such file or directory
> make[6]: *** [fastdep] Error 1
> make[6]: Leaving directory `/usr/src/kernel-source-2.4.21/drivers/acpi'
> make[5]: *** [_sfdep_acpi] Error 2
> make[5]: Leaving directory `/usr/src/kernel-source-2.4.21/drivers'
> make[4]: *** [fastdep] Error 2
> make[4]: Leaving directory `/usr/src/kernel-source-2.4.21/drivers'
> make[3]: *** [_sfdep_drivers] Error 2
> make[3]: Leaving directory `/usr/src/kernel-source-2.4.21'
> make[2]: *** [dep-files] Error 2
> make[2]: Leaving directory `/usr/src/kernel-source-2.4.21'
> make[1]: *** [dummy_do_dep] Error 2
> make[1]: Leaving directory `/usr/src/kernel-source-2.4.21'
> make: *** [stamp-kernel-configure] Error 2
> Whats wrong ?

You used the kernel-source package, right ?

This package has already various patches applied, see package 
description: "This package provides the source code for the Linux 
kernel version 2.4.21 with modifications by Debian.".

Therefore your patch does not apply cleanly. Please try downloading
the kernel source from kernel.org and then apply your ACPI patch. 


LuMriX - XML Search Engine - http://www.lumrix.de/

Reply to: