[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autoloading module for pcmcia network card

Am Mit, 2003-04-02 um 14.53 schrieb Thomas Friedrichsmeier:
> Hi!
> After I finally broke off the adaptor-cable of my old network-card, I now have 
> a new noname 8139-based one.
> Problem is, that the cardmgr can find and activate the card, but does not load 
> the required modules or start the interface. The card works just fine, if I 
> modprobe the 8139too-module and configure the interface by hand, but I'd 
> rather have this happen automatically, like it worked with my old card.
> The following gets logged to /var/log/messages when I do /etc/init.d/pcmcia 
> start:


> I tried adding the following lines to /etc/pcmcia/config:
> device "8139too"
>   class "network" module "net/8139too"

Try removing "net/"

> card "NoName 10/100"
>   manfid 0x10ec, 0x8139
>   bind "8139too"

You may want to add this to /etc/pcmcia/config-2.4 if it exists.
At least on my system only config-2.4 is used.

If this doesn't help you can still do an echo "8139too" >> /etc/modules
which will load the module in any case on a reboot.


Matthias Hentges 
Cologne / Germany

[www.hentges.net] -> PGP welcome, HTML tolerated
ICQ: 97 26 97 4   -> No files, no URL's

My OS: Debian Woody: Geek by Nature, Linux by Choice

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

Reply to: