[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't get 3Com LAN/modem to work on Thinkpad770

Hello folks,
I am a newbie who needs help troubleshooting a LAN/Modem card that I added to a ThinkPad 770, which my Debian 3.0 install cannot use. I think it is an IRQ or memory conflict, but I don’t know how to troubleshoot it. Unfortunately, if I cannot get this card to work, I cannot connect this computer to another local machine, nor the internet.

During the boot sequence, the two last lines that print to screen before the X server starts offer a clue. I can only see them for about 2 seconds, but I think they say something like:
cs: could not allocate 512 IO ports for CardBus socket 0
3c575_cb: requestIO: out of resource

Basic hardware:
IBM ThinkPad770 model 954830U w/13.3” XGA TFT screen
CPU: Intel Pentium ‘Tillamook’ 233 MHz with MMX
Memory: 256 MB SDRAM installed (the maximum)

PCI devices with the IRQ set to 11:
Video card: Trident Video Accelerator 3D Cyber 9397;
PCI bus 0, device 3, function 0;
IRQ=11, I/O=03B0-03BB,03C0-03DF
PCMCIA adapters: Texas Instruments PCI-1250 CardBus controller;
PCI bus 0, device 2, function 0 (second slot: function 1)
IRQ=11. Unfortunately I didn’t write down the I/O or memory range.
LAN/Modem: FEM656C-3Com Global 10-100+56k CardBus (plugged into upper PCMCIA slot)
IRQ=11, I/O range=FF00-FFFF
USB controllers: Intel 82371 AB/EB PCI to USB universal host controller USB root hub
IRQ=11. I/O=8400-841F

In one attempt to troubleshoot the problem I ran modconf, and these are my notes:
0: 291833 xt-pic timer
1: 858 xt-pic keyboard
2: 0 xt-pic cascade
11: 4 xt-pic i82365
12: 119854 xt-pic PS/2 mouse
13: 1 xt-pic fpu
14: 212248 xt-pic ide0
15: 8 xt-pic ide1

Reply to: