[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

alsa not working: step-by-step



Dear All,

The quest continues.  Alsa is still not working, but my hunch now is that
for some reason the new kernel and alsa modules are not being accepted into
the system - which behaves as if it's running with the old kernel.  Briefly,
I edited /etc/modules.conf, recompiled the kernel and reinstalled alsa from
source.  When none of that worked I tried insmod which revealed some
disagreements (between me and the computer) over which kernel we were
running (see section *** WHICH KERNEL VERSION ??? below).

I decided this time to keep a step-by-step log - maybe I've missed something
so yawningly obvious, everyone is too polite to suggest it.  Here it is; all
comments welcome:


*** /ETC/MODULES.CONF

I followed the instructions from the 'alsa-project.org/alsa-doc::Analog
Devices AD1881A' page: mainly, inserting these lines to
/etc/modutils/aliases and running update-modules.

        # ALSA portion
        alias char-major-116 snd
        alias snd-card-0 snd-intel8x0
        # module options should go here

        # OSS/Free portion
        alias char-major-14 soundcore
        alias sound-slot-0 snd-card-0

 # card #1
 alias sound-service-0-0 snd-mixer-oss
 alias sound-service-0-1 snd-seq-oss
 alias sound-service-0-3 snd-pcm-oss
 alias sound-service-0-8 snd-seq-oss
 alias sound-service-0-12 snd-pcm-oss


*** DSELECT

- From dselect::Choose packages

The following NEW packages will be installed:

# chosen by me
alsa-base alsa-headers alsa-source alsa-utils alsaconf
apt-file kernel-headers-2.4.18 kernel-headers-2.4.18-686
kernel-source-2.4.18  libasound2

#chosen by dselect
libappconfig-perl libasound2-dev libcrypt-ssleay-perl
libdigest-md5-perl libhtml-format-perl
libhtml-parser-perl libhtml-tagset-perl
libhtml-tree-perl libio-socket-ssl-perl
libmailtools-perl libmime-base64-perl libnet-perl
libnet-ph-perl libnet-snpp-perl libnet-ssleay-perl
libnet-telnet-perl libtimedate-perl liburi-perl
libwww-perl openssl

0 packages upgraded, 29 newly installed, 0 to remove and 0  not upgraded.

- From dselect::Install and upgrade wanted packages
 --with cards intel8x0
 --with ISA PnP yes


*** COMPILING KERNEL AND ALSA SOURCES

Following instructions from file:///usr/share/doc/alsa-source/README.Debian

- unpacked kernel-source-2.4.18.tar.bz2 and alsa-driver.tar.gz in /usr/src.

- got kernel config file from previous kernel build (i.e. CONFIG_SOUND=m,
all other sound options not set - including CONFIG_SOUND_ICH).

- make menuconfig.

- make dep.

- make-kpkg --revision=forAlsa.1.0 kernel_image.

- building the alsa modules.  Although I ticked the 'intel8x0' box during
dselect (see above), I can't find any conf files with this set (for example,
/etc/alsa/alsa-source.conf leaves ALSA_CARDS undefined).  I'll go for the
belt and braces approach: (a) edit /etc/alsa/alsa-source.conf manually, and
(b) set ALSA_CARDS on the command line.

- export MODULE_LOC=/usr/src/modules/.

- ALSA_CARDS=intel8x0 make-kpkg --revision=forAlsa.1.0 modules_image.

- dpkg -i kernel-image-2.4.18_forAlsa.1.0_i386.deb.

- dpkg -i alsa-modules-2.4.18_0.9+0beta12+3+p0+forAlsa.1.0_i386.deb.

All this went fine.  Rebooted and saw the 'No ALSA driver installed' message
scroll past.  After logging in, running alsactl prompted the 'No ALSA driver
installed' message too.


*** WHICH KERNEL VERSION ???

I had a go at inserting the modules manually.  This got an interesting error
message:

debian:/lib/modules# ls
2.4.18 2.4.18-bf2.4
debian:/lib/modules# cd 2.4.18/alsa/
debian:/lib/modules/2.4.18/alsa# ls
snd-ac97-codec.o  snd-pcm.o         snd-seq.o
snd-intel8x0.o   snd-seq-device.o      snd-timer.o
snd-mixer-oss.o   snd-seq-midi-event.o  snd.o
snd-pcm-oss.o     snd-seq-oss.o
debian:/lib/modules/2.4.18/alsa# insmod snd-intel8x0.o
snd-intel8x0.o: kernel-module version mismatch
 snd-intel8x0.o was compiled for kernel version 2.4.18
 while this kernel is version 2.4.18-bf2.4.

I had originally installed Debian GNU/Linux with the bf24 option, i.e. using
the 2.4.18-bf2.4 kernel.  Looking into this, I saw that
/etc/modutils/alsa-path contained:

path=/lib/modules/`uname -r`/alsa

For some reason, even after recompiling the kernel today uname is giving me

debian:~# uname -a
Linux debian 2.4.18-bf2.4 #1 Son Apr 14 09:53:28 CEST 2002 i686 unknown

That doesn't seem right.  Anyway, /lib/modules/2.4.18-bf2.4/ doesn't contain
any alsa modules, which are all in /lib/modules/2.4.18/.  I edited
/etc/modutils/alsa-path to:

path=/lib/modules/2.4.18/alsa

And ran update-modules, for some new error messages:

debian:/etc/modutils# update-modules
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-ac97-codec.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-intel8x0.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-mixer-oss.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-pcm-oss.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-pcm.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-seq-device.o
depmod: *** Unresolved symbols in
/lib/modules/2.4.18/alsa/snd-seq-midi-event.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-seq-oss.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-seq.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd-timer.o
depmod: *** Unresolved symbols in /lib/modules/2.4.18/alsa/snd.o
debian:/etc/modutils#

When I reboot, these messages scroll past, sometime before the 'No ALSA
driver installed' message.  However, neither of these is in
/var/log/messages.  Is there another boot messages file for this kind of
stuff?

My general feeling is that the machine still thinks it's running with the
2.4.18-bf2.4 kernel (maybe it is?) and is either not reading the new alsa
stuff or is not linking it in correctly.

Best wishes

Ivan




Reply to: