[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can boot 2.2 but not 2.4 kernel

I have a Gateway Solo 5150 (now 3 1/2 years old) with an IBM DKLA 4.2GB

It's dual boot Win2k and Debian Testing. Originally I installed 2.2R0
with a 2.2.17 kernel. About 6 months ago I installed the deb kernel
image of 2.4.17-686, as I have a USB printer and wanted to move to a 2.4

I was running out of disk space and, as I have had previous success with
Partition Magic, bought the latest version - 7.0.
The setup of the drive:

hda1(NTFS) hda3 <hda5(NTFS) hda6(/VAR ext2)> hda4(linux Swap) hda2(/

There was some free space between hda1 and hda3 so I moved hda5, and
hence hda3 down, expanded hda6, moved hda4 down and expanded hda2. That
all worked just fine and I was able to make an "apt-get dist-upgrade"
download of 130MB.

PM suggested running "chkdsk" /f which I did, and boy was that a

The D: drive hda5 no longer has a drive letter and booting Linux gives a
succession of drive errors followed by kernel panic. As the drive is
never mounted there are no logs.

I had kept the original 2.2.17 kernel and have a boot floppy. The 2.2.17
kernel boots just fine and hda6 mounts as /VAR without any problem as

When I installed the 2.4 kernel I followed the suggestion to use  the
initrd.img under lilo. So in lilo.conf I have


The machine is booted using the W2k loader with a copy of the linux 
(/dev/hda2) boot sector, as in the NT HOW-TO. Lilo is installed on hda2.

I'm wondering if moving the hda2 down, to expand it, has somehow caused
the problem. I made a new copy of the boot sector when I did so and all
worked until I ran "chkdsk /f". 
Again I reran lilo and copied the bootsector, after this problem
occured, but without any success.

Could chkdsk have corrupted some part of the boot sector or image?

Any suggestions would be welcome.

   Tim Wood

To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: