[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

infraport on ibm thinkpad



Hello,

 I have IBM Thinkpad a22m, I would like to dial out using my Nokia 6210
 phone. I tried it on this notebook with freebsd, it worked with almost
 no problems. Since the IRDA support is much different, I have really
 trouble making it work under Debian GNU/Linux. I deleted freebsd
 because of some hardware problems and since there are experimental
 packages for KDE 3.0, I like debian here.

 So, infraport is enabled in the BIOS, findchip reports this:

NSC,PC87338,11.2,0x2e,0x2f8,0x2f8,3,3,1,0,1

 I have latest testing 2.4.18 kernel (from woody) and:

ii  irda-common    0.9.14-17      IrDA management utilities
ii  irda-tools     0.9.14-17      IrDA handling tools

 this is the irda0 part of ifconfig:

irda0     Link encap:IrLAP  HWaddr 7c:ab:cb:4e
          UP RUNNING NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 b)  TX bytes:30 (30.0 b)

 modules:

jurajbug:/home/juraj# lsmod|grep ir
ircomm-tty             30112   0  (autoclean)
ircomm                 13180   0  [ircomm-tty]
irtty                   7296   2  (autoclean)
irda                  137996   1  (autoclean) [ircomm-tty ircomm irtty]

 I've read the Infrared-HOWTO, etc. I'm unable to load nsc-ircc.o module, I don't
even know if I need it. On freebsd, I just used /dev/ttyS1. My kernel
reports it has found ttyS1 port:

[root@idoru juraj]# dmesg|grep tty
ttyS01 at 0x02f8 (irq = 3) is a 16550A

 but playing with irattach (irattach /dev/ttyS1 -s 1, irattach irda0 -s 1,
 irattach nsc-ircc -s 1) yields to no results. 

 jurajbug:/home/juraj# cat /proc/net/irda/discovery
 IrLMP: Discovery log:

 (i.e. discovery log is always empty).

 My question is -- if some of you have tried this (to any ,,serial''
 device). What is the proper syntax of irattach (what do I attach
 where)? I tried communicating through /dev/ircomm0 and /dev/ttyS1 ports
 using minicom. No results. If I'm able to send some AT command, I will
 figure out the rest.


    Thank you,


      Juraj.

P.S.: Just switched from Mandrake and FreeBSD to Debian, it has the
nicest way of building the kernel. Wow!
 
 
-- 
Juraj Bednar             | Homepage at http://juraj.bednar.sk/     
computer journalist      | Store at http://www.geekstore.sk/        
system administrator     | PGP key: http://juraj.bednar.sk/pgp-key   
independent consultant   | Please stand for your freedom!            

Attachment: pgpqEWblEjtCK.pgp
Description: PGP signature


Reply to: