[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: E-Tech 56K6 PCMCIA modem

Hello again,

During this weekend I tried to find where the actual problem lies: PCMCIA or
I think, something is wrong with my PCMCIA config. A checked docs, but still
don't quite understand what I should do. Shortly:

1. I found out that in windows my modem is on IRQ 9. As far as I understand, it
means that I must make the same setting in Linux, right? 
If I do "cat /proc/interupts" it shows for the IRQ 9 i-module name (don't
remember it exactly - i86...) from the PCMCIA package. 
If I do "cardctl config" it shows IRQ 3. 
If I try to force it to use IRQ 9 by "setserial /dev/modem irq 9" thing look
very strange, because "cardctl config" shows IRQ 10 (NOT 9!!!).

So I'm completely stuck with this IRQ stuff.

2. Minicom accepts all AT commands I issue and says always OK if I run it with
default configuration (without any changes of IRQ's and so on). 
It uses correct device (/dev/ttyS18, /dev/modem is actually only a link).
If I do some "setserial" stuff, no AT commands get accepted by minicom.

3. My modem DOES reply to AT commands with some useful information in
Windows2k: I use hyperterminal, then ATZ,  ATV1 and then to some commands it
prints info, not just OK.
I also fetched init string from win-config - does not change anything in Linux.

So, I absolutely do not know what to do. 
What do you think - is it PCMCIA confi problem or smth else.
Any help will be really appreciated!


Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup

To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: