[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: via82cxxx

> > I've got a question about sound configuration.
> > I know I have a VIA  PCI audio controller :
> > I/O 220-22F
> > IRQ 5
> > and it seems to be sound blaster compatible.
> > 
> > What should I do to get it working ???
> > 
> > Many thanks in advance,
> > Olivier.

> I had the same problem about 2 months ago.... the solution : install 
> kernel 2.4.0 test 5 or better. I have test 5 on my machine right 
> now(I'll get the latest kernel later on, when it's stablised maybe).

> just modprobe soundcore, ac97something and then via82cxxx. works like a 
> charm
> Pat


I'm having a similar problem, exact same config as Olivier
mentioned (sb io=0x220, irq=5, synth io=0x330).  Can't find 
any place to indicate what the base io addr is for this sound 
card (presumably this is only necessary in legacy mode?  oddly, 
there is a way to spec the synth's io port.)  Kernel is 2.4.6
(have also tried with earlier kernels from stable and testing).  
CPU is duron 800 and VIA chip is shown in lspci as a VT82C686 
(note: no A or B suffix).  Just tried your (Pat's) suggestion:

dude:~# modprobe soundcore [success]
dude:~# modprobe ac97_codec [success]
dude:~# modprobe via82cxxx_audio
/lib/modules/2.4.6/kernel/drivers/sound/via82cxxx_audio.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.6/kernel/drivers/sound/via82cxxx_audio.o: insmod /lib/modules/2.4.6/kernel/drivers/sound/via82cxxx_audio.o failed
/lib/modules/2.4.6/kernel/drivers/sound/via82cxxx_audio.o: insmod via82cxxx_audio failed

I have been able to load sb.o but this is not useful as apps
complain about only having 8-bit audio :(.

Thanks for any assistance or suggestions.

Reply to: