[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't compile pcmcia-source

>>>>> "Mark" == Mark Phillips <mark@ist.flinders.edu.au> writes:

    Mark> I'm trying to compile the pcmcia-source (3.1.22-2) and I can't get it
    Mark> to work.  I tried compiling it on a different machine, and it failed,
    Mark> but this time with a different error message:

[cut large error message]

    Mark> Any ideas about what is wrong?

Lemme guess.  You're compiling a 2.4 kernel, and you enabled PCMCIA support in
the kernel, right?  That happened to me, too, and I eventually fixed it, but it
seems like the PCMCIA stuff in 2.4 doesn't work properly anyways, so you'll
probably want to disable the kernel PCMCIA, recompile, and everything should be

But if you want to try out the kernel PCMCIA stuff, I fixed it by editing the
Makefile.  It looks that particular directory is stuff that is supposed to be
part of the kernel, so the Makefile is two parts.  If you select to compile the
kernel PCMCIA part, then the first bit of the Makefile is used, which basically
prints out a warning that it won't compile the files in that directory, and
quits.  Unfortunately, the first bit is lacking an "install" rule, which is
what causes the error, but I think you can just add an "install" rule, with no



____     |     -----------------------------------------------------------
|  /   --+--
| /   ___|___    Hubert Chan <hackerhue@crosswinds.net>
| \   | _|_ |
|__|  |__|__|    GCS/M d- s:- a-- C++ UL+(++++) P++ L++ E++ W++ N++ o?
|        |       K? w--- O++ M- V- PS-- PE+++ Y+ PGP+ t+ 5 X R- tv+ b+
|      / | \     DI++++ D G e++ h! !r !y
|     /  |  \
|        |     <><------------------ http://www.crosswinds.net/~hackerhue/

PGP/GnuPG fingerprint: 6CC5 822D 2E55 494C 81DD  6F2C 6518 54DF 71FD A37F
Key can be found at http://www.crosswinds.net/~hackerhue/hackerhue.asc

Reply to: