[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound problem. 'insmod sb' failed.

Thanks very much for your help! 

It still doesn't work. I tried different irq and io, when 'insmod sb'.
it always gives me 'device or resource busy...irq or io isn't set

I am using Debian 2.2, kernel 2.2.17.

My laptop is TwinHead Slimnote VX3. The BIOS is PhonixNote 4.0 version
6. I couldn't find anything about PCI or PnP in CMOS setup.

I got some infomation about my sound chip as follow:

when doing 'lspci -vv', I got:

00:06.0 Multimedia audio controller: Creative Labs: Unknown device 8938
	Subsystem: TWINHEAD INTERNATIONAL Corp: Unknown device 0e70
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 5
	Region 0: I/O ports at fcc0
	Region 1: I/O ports at fc40
	Capabilities: [dc] Power Management version 1
		Flags: PMEClk- AuxPwr+ DSI+ D1+ D2+ PME+
		Status: D0 PME-Enable+ DSel=0 DScale=0 PME+

in /proc/pci, I got:

  Bus  0, device   6, function  0:
    Multimedia audio controller: Unknown vendor Unknown device (rev 0).
      Vendor id=1102. Device id=8938.
      Slow devsel.  IRQ 5.  Master Capable.  Latency=96.  Min Gnt=12.Max Lat=128.
      I/O at 0xfcc0 [0xfcc1].
      I/O at 0xfc40 [0xfc41].

And I got these modules in my /lib/modules/2.2.17/misc/, I am not so
sure which one is useful besides soundcore, soundlow, sound and sb.

  23 ad1848.o
   3 adlib_card.o
  64 awe_wave.o
  10 lp.o
  17 opl3.o
  15 parport.o
  11 parport_pc.o
   6 parport_probe.o
  48 sb.o
  84 sound.o
   7 soundcore.o
   2 soundlow.o
  76 sunrpc.o
  10 uart401.o

> > Win98 shows:
> > 
> > Creative SB AudioPCI 64V,
> > 	SoundBlaster: io=220 dma=3 irq=7
> > 	Soundscape: Base/MIDI port=330 WavePort=534 dma=3 irq=7
> > 	MPU-401: io=330 irq=7
> > 	AdLib port=388
> > 


> I can't help much here. It depends on your computer. If your BIOS allows 
> this, try to change the IRQ of the sound card ( I did it, because IRQ 7
> was used by the parallel port also ... )
> Just in case it might help,  I'll add here the section of my /etc/modules.conf related to
> the sound:
> alias char-major-14  sb
> options sb io=0x0220 irq=5 dma=1 mpu_io=0x0300
> post-install sb /sbin/modprobe "-k" "adlib_card"
> options adlib_card io=0x0388
> pls note that my IRQ and IO addresses are different ...
> Ciao
> -----
> FB 

       __o?     o
     _`\<,_     Z
    (_)/ (_)   />

Reply to: