[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCMCIA oddities with 2.2.15 on TP 760ED

Hi All.

Due to a hard drive failure I decided to update my Slink system on
an older/smaller drive on my ThinkPad 760ED to Potato.  All went well, 
so today I decided to update the kernel to 2.2.x and update the PCMCIA 
as well.

As luck would have it, 2.2.14 (which had worked flawlessly for me in the
past) wasn't available anymore, so I chose 2.2.15 and the related 
PCMCIA-modules package.  As insurance I downloaded the source for both.  
The only thing I use PCMCIA for is the 56k Megahertz modem which had 
worked great until this point.

I rebooted the system and was greated by a slew of unresolved symbol
errors and a non-working modem.  So I compiled a custom kernel using
kpkg and also compiled the PCMCIA package.  Had some trouble installing
them since the kernel maintainer advanced the epoch to 1 and the
custom kernel was set to 0.  But they are installed.  Upon reboot
I still have one unresolved symbol error coming from the module
dependencies calculations and it is:

depmod: ***Unresolved symbols in /lib/modules/2.2.15/pcmcia/epic_cb.o

Other than that, there are no obvious errors during init.

pppd files to work and in its log it complains of not being able
to get terminal parameters, reports and Input/Output error and

In /var/log/messages, I find the serial driver is loaded and finds
the built-in port as shown, but the PCMCIA modem is on a wild port
and IRQ:

kernel: Serial driver version 4.27 with no serial options 
kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A            
kernel:     ISA irqs (scanned) = 5,7,9,10 status change on irq 10               
kernel: tty01 at 0x13f8 (irq = 5) is a 16550A             

Looking at the same log file from when I booted 2.0.36 this morning,
I find a different report:

kernel: Serial driver version 4.13 with no serial options enabled               
kernel: tty00 at 0x03f8 (irq = 4) is a 16550A                                   
kernel:     ISA irqs (scanned) = 3,4,5,7,9,10 status change on irq 10           
kernel: tty01 at 0x02f8 (irq = 3) is a 16550A                                   

So, can anyone tell me why PCMCIA is not seeing IRQs 3 and 4 now and
why it's assigning tty01 to 0x13f8?  Perhaps some kind soul can tell
me how to override this configuration and force it to be normal.
Strangely, although it assigns tty01 to ttyS1 at 0x13f8 (irq =5),
pppd can't find it.

What do I do next?


- Nate >>


 Wireless | Amateur Radio Station N0NB          | "None can love freedom
 Internet | n0nb@networksplus.net               | heartily, but good
 Location | Wichita, Kansas USA EM17hs          | men; the rest love not
   Wichita area exams; ham radio; Linux info @  | freedom, but license."
             http://www.qsl.net/n0nb/           | -- John Milton

Reply to: