[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Knoppix 6.4.4 and the X11 Compose Key

Hello Klaus,

Thanks you for your reply, which suggested a few more things to try. I've stumbled on a solution.

I am slightly unusual: when I install Linux (e.g. Debian), I select keyboard US but language/location British/UK.

With Knoppix, I always used to let the boot default to lang=us. I'd read about the chap who tried lang=uk and got a dead Ukrainian keyboard so I wasn't going to try that.

I removed lang=us from the lines in syslinux.cfg and tried to find a combination that worked by changing /etc/sysconfig/keyboard and friends instead of editing knoppix-autoconfig, which is what I probably should have done.

I tried LANG=en_GB.UTF-8 as that is what I have under Debian. Knoppix does not like this one bit. The bash shell keeps complaining that it cannot set the locale. Neither en_US.UTF-8 nor en.UTF-8 work but fi_FI.UTF-8 does. I speculated (for I was really on the edge of what I do know) that this is to do with how internalisation is compiled into Knoppix to keep down the size.

I gave up this approach leaving just LANG=en_GB, more or less, by accident. Somehow this gets changed to LANG=en_GB.ISO-8859-1 by the time I get to open a virtual terminal and the compose key now works as expected. So the issue is a locale issue.

So, for the record, I'm now running with:


This last I should probably change to iso8859-1but I am running Eclipse and Python and exchanging sources files in several programming languages with Windows and other Linux systems that are using Unicode.

I also have (note my eccentric choice of keyboards)

KEYTABLE="us" # instead of uk meaning the United Kingdom

This last appears to be obsolete under KDE 4.


P.S. I had a nice row of four penguins early in the boot of 6.4.3 but these have disappeared in 6.4.4. I hope they come back soon.

Reply to: