[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Not a valid device block


Did I already answer this?

On Tue, Aug 30, 2005 at 04:29:16AM -0700, Nemesis golicha wrote:
> i tried mounting my usb flash on /dev/sda1 and thats
> the error i got i had already edited my /ect/fstab and
> added 
> /dev/sda1 /mnt/flash vfat noauto,users,unmask=0 0 0
> then i created dir flash in /mnt.
> when i try mounting it with mount /mnt/flash i get the
> msg /dev/sda1 is not a valid device block i have tried
> it also with uba,uba1,sda...8 and still it wont work
> any help would be appreciated. i hope am not a
> nuisance its just that i have tried everything i have
> googled. 

It may help if you check /proc/partitions for presence of a new block
device that looks like your flash. If it doesn't appear there, something
is wrong.

It may also be the cae that your USB controller has misconfigured
interrupts (happens occasionally with BETA ACPI bioses), in which case
you should boot with

knoppix acpi=off pnpbios=off noapic pci=bios

(one of these options is usually sufficient, but you never know...)

Also, looking into the output of


can sometimes be helpful.

-Klaus Knopper

Reply to: