[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#928191: firmware-iwlwifi: WiFi-breaking regression in latest Stretch point release (9.9), pkg ver 20161130-5 (includes solved workaround)

Package: firmware-iwlwifi
Version: 20161130-5
Severity: important
Tags: upstream

After the most recent point release upgrade, performed on a stock Debian Stable
amd64 system with 'apt-get update ; apt-get dist-upgrade', in which the package
firmware-iwlwifi was upgraded to a newer version (amongside many other packages
- I cannot be certain this one is positively the cause), all tested WiFi
internet connections that worked fine previously no longer connect. Instead,
the NetworkManager applet in my desktop panel only shows the "connecting"
animation for about 10 seconds, then silently fails to the standard
"disconnected" icon, with no successful internet connection. Previously these
tested connections were successful within one or two seconds of selecting the
desired network from the NM drop-down list.

Hardware info (with the "#" sign at the start of a line indicating a root
command prompt):

# lspci -nnvv | grep Network
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6235
[8086:088e] (rev 24)

This is a very common card and hopefully other users are not being impacted in
the same way I have been

Successful solved workaround:

Unload and reload the two kernel modules 'iwlwifi' and 'iwldvm'. I perform this
with these commands:

# rmmod iwldvm
# rmmod iwlwifi
# modprobe iwlwifi

After this, the connections all work correctly and as expected and experienced
before the 9.9 release.

Thank you to all the Debian Developers, Maintainers, and all other excellent
people working to make technology that helps the world.

-- System Information:
Debian Release: 9.9
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-9-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

firmware-iwlwifi depends on no packages.

firmware-iwlwifi recommends no packages.

Versions of packages firmware-iwlwifi suggests:
ii  initramfs-tools  0.130

-- no debconf information

Reply to: