[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: armel/marvell kernel size

On Mon, Jul 31, 2017 at 3:05 AM, Roger Shimizu <rogershimizu@gmail.com> wrote:
> While I'm still working on this, but I find the latest kernel in
> archive, 4.11.11-1+b1, fails to boot on my kirkwood based Linkstation.
> I tried netconsole, but don't get any log. (netconsole outputs fine on
> working kernels, such as 4.9 and 4.10 series.)
> And I trace to latest working kernel is 4.10.7-1~exp1.
> 4.11-1_exp[12] FTBFS on armel, and 4.11.3-1_exp1 doesn't boot.
> I checked d-kernel and d-arm list, but didn't find similar issue.
> Do you have any clue on this? Thanks!

I think my problem is very likely the same as:
 - https://bugs.debian.org/870185

And I tried Ben's recommendation to make armel kernel smaller,
which I pushed to branch rosh/strip_armel on alioth, confirmed it worked
well for 4.10.7-1~exp1 (by cherry-pick) on my kirkwood based Linkstation.

I know it's better to confirm the d-i part, but I don't have much time before

Roger Shimizu, GMT +9 Tokyo
PGP/GPG: 4096R/6C6ACD6417B3ACB1

Reply to: