[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#652459: initramfs-tools: [patch] Please support mounting of /usr in the initramfs

Where are we as far as releasing something in "experimental" or "unstable" to address this?  Debian's decision to go with "systemd" in the upcoming release (jessie) should rightfully increase the sense of urgency a bit.

I run on an Alpha PWS 433au, which means I run "sid" if I want to run anything current as far as software.  Because the machine was originally configured back when dinosaurs roamed the earth, I have "/usr" on a separate partition.  The upgrade to "systemd" has caused no small amount of pain (because of the requirement that "/usr" be available when "systemd" starts running), but a fix for #652459 will mitigate most of the issues I'm seeing.

Yes, I'm willing to test patches for the specific case of "/usr" not being on the same file system as "/".  I'll be trying the already-submitted patches against the 0.115 initramfs-tools source in a few days.

As always, thanks in advance.

--Bob Tracy

Reply to: