[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#728993: firmware-linux-nonfree: Requesting xc5000 firmware (dvb-fe-xc5000c-

Package: firmware-linux-nonfree
Version: 0.40~bpo70+1
Severity: normal

Hello there,

In recent kernels (since 3.7, I believe; see commit below), the xc5000 driver
lists two different firmware files it can make use of:

# uname -a
Linux debian 3.10-0.bpo.3-amd64 #1 SMP Debian 3.10.11-1~bpo70+1 (2013-09-24)
x86_64 GNU/Linux

# modinfo xc5000
firmware:       dvb-fe-xc5000c-
firmware:       dvb-fe-xc5000-1.6.114.fw

However, the firmware-linux-nonfree package contains only dvb-fe-

# dpkg-query -L firmware-linux-nonfree | grep dvb-fe-xc5000

Both firmware files are available from http://kernellabs.com/firmware/xc5000/,
and appear to be released under identical licenses (see also the relevant

Is it possible to please include dvb-fe-xc5000c- in firmware-linux-
nonfree?  I have a (relatively new) WinTV-HVR-950Q TV tuner device, and I have
discovered that having dvb-fe-xc5000c- in /lib/firmware is necessary
to make this device work.  When only dvb-fe-xc5000-1.6.114.fw is present, the
xc5000 module loads that firmware without error, but the device does not work
(cannot tune or watch TV channels).

Thanks! :)

-- System Information:
Debian Release: 7.2
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.10-0.bpo.3-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

firmware-linux-nonfree depends on no packages.

firmware-linux-nonfree recommends no packages.

Versions of packages firmware-linux-nonfree suggests:
ii  initramfs-tools                               0.113~bpo70+1
ii  linux-image-3.10-0.bpo.3-amd64 [linux-image]  3.10.11-1~bpo70+1
ii  linux-image-3.2.0-4-amd64 [linux-image]       3.2.51-1

-- no debconf information

Reply to: