[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#684265: Debian Installer 7.0 Beta2 release bug #684265

On Sep 10, 2012, at 10:16 PM, Christian PERRIER wrote:

Quoting Rick Thomas (rbthomas@pobox.com):

I'll be happy to provide installation log files to anyone who wants

I'd also be happy to look at the relevant code and see if I can
figure out what's wrong, but I don't know where to look.  I don't
have any experience with the insides of the installer.  If somebody
is willing to mentor me a little I might be able to help.

It's likely to be in os-prober.

When I run os-prober on the installed system, I get exactly what I expect:

    /dev/mapper/monk-root:Debian GNU/Linux (6.0.5):Debian:linux
    /dev/mapper/monk-root2:Debian GNU/Linux (wheezy/sid):Debian1:linux

There are three root partitions monk-root, monk-root2, and monk- root3. The last is the active root at the time os-prober was run, so I don't expect it to show. It does find the other two, though.

The PowerPC system that shows the bug is not using LVM. On that machine the extra Linux root partitions are real physical partitions. On that machine I also get the expected results from running os-prober in the installed system.

So if the problem is in os-prober, it's not in the part of os-prober that gets used in the installed system, it must be in the parts that are unique to the installation system.

I have not tried running os-prober from the <alt>-F2 console during the install, to see if it gives different results. I'll do that and report back. Any hints of things I should be looking out for?



Reply to: