[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#673496: It's alive, Jim.

Jonathan Nieder <jrnieder@gmail.com> wrote:>Is this summary of your experience with the ath5k card correct?
> behavior on lenny:	always worked 

Yes, it worked fine in Lenny.

>behavior on squeeze:	broken, symptoms not described yet 

The problem was just as described in bug 604613, which you cloned this from. 
The card seemed to work, in that it would be recognized by the system and
you could scan for APs. But it would never, ever be able to get an IP address
from any AP. Yet, I could plug in an external device and that worked fine. The
connection linked up and IP address was assigned. When I got another card 
from eBay, that also worked fine. I even tried killing wicd and using the manual
iwconfig method. That didn't work either. So, I was forced to conclude that the 
problem was with the kernel driver.

After searching for a while, I found bug 604613 and started replying to it.

One further update, though, now that I've put it back in the machine I tried it
again just to be thorough. It WORKS now! (scratching head...) All I can guess
is that one of those two kernel updates that have come out since I first tried to
get it to work have changed something that resolves the problem. Yet I didn't
see anything in the change log that I would associate with the ath5k driver.
Maybe you can make a better guess at what it might be. So far I've used the
machine three times including when I first discovered that it works now. 

Any other ideas on what might have changed? I know wicd had an update
related to security, but like I said, I had tried using iwconfig in case the problem
was with wicd and it didn't change anything. Still could not get IP address.

> behavior on wheezy:	card only detected ~50% of the time
> detected, it works (?) 

The 3.2 kernel can't load X, but locks up solid, so I've never gotten the
chance to try. When I started in "recovery" mode I tried to find the card 
and it didn't show up. So 1 out of 1 times it didn't detect it -- when in
recovery mode. Are there things related to network that are not loaded or 
initialized in recovery mode?

Further weirdness, as I said before, the machine locked AFTER I had run
the 3.2 kernel in recovery mode and then tried to reboot into the default
stable Squeeze kernel. That seems to mean that it's not necessarily X that
causes the problem. The 3.2 kernel seems to be doing something very, very
wrong at the hardware initialization level. It took a cold shutdown and 
restart to be able to run even the Squeeze kernel.

Reply to: