[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#660554: [Pkg-xen-devel] Boot process hangs then reboots when using Xen + Linux 3.2

On 03/01/2012 11:53 PM, Bastian Blank wrote:
> On Thu, Mar 01, 2012 at 06:02:15PM +0800, Thomas Goirand wrote:
>> On 03/01/2012 04:55 PM, Bastian Blank wrote:
>>> Broken ACPI table, aka firmware bug.
>> Do you then suggest I try upgrading my BIOS? It's the one providing the
>> ACPI tables, right?
> Yes.
>>                     Any clue why I don't see crashes without Xen, with a
>> 64 bits kernel, or with earlier versions of Linux (eg: 3.1 for example)?
> xen/i386 uses a different memory model to anything else, this may be a
> problem.
>>      Then I just tried upgrading today to 3.2.7-1, and it seems there's
>> the exact same issue (I didn't care doing a serial dump, but I can if
>> you wish).
> The stack trace and the surrounding would be nice, there are some weird
> inconsistences.
> Bastian

Replacing BUG_ON by a WARN_ON, and adding #define DEBUG 1 on top of
dma_v2.c, my kernel booted, and I had the attached dmesg output.

Blacklisting the ioatdma kernel module of course, solved the issue.

I hope that helps, please let me know if I should do more to help. If
you need access to my server, that's possible (I use it only for
packaging XCP and some tests...).


Attachment: dmesg.txt.gz
Description: GNU Zip compressed data

Reply to: