[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#661558: linux-image-3.2.0-1-amd64: kernel oops when adding a bitmap to a raid1 md device



Package: linux-2.6
Version: 3.2.4-1
Severity: normal

The kernel oopsed on me after I added a bitmap to a RAID1 md device with:

  mdadm --grow /dev/md2 --bitmap=internal

This happened to me during normal operation -- twice, because I hoped the
first time it was just bad luck. Then I booted with init=/bin/bash, i.e.
nothing but the bare kernel, built a RAID1 on two spare partitions, added a
bitmap as described above and it oopsed again as soon as I tried to write
something to the device. I was able to capture some traces with my phone's
camera; this is my home computer so I'm not able to get a better trace with
netconsole or a serial port. Might however try at work if necessary.

The first picture (27022012040-25%-gray.png) is the bottom part of a trace;
the rest scrolled away while I opened the phone, so I tried again and got
the second picture (27022012041-25%-gray.png) but it looks like there's no
overlap in the functions listed.

FYI, mdadm is version 3.2.3-2.

Also, unfortunately I just launched a dist-upgrade and didn't notice that
kernel version 3.2.6-1 was in the list :(
I haven't rebooted yet, but this means I might not be able to try again with
version 3.2.4-1. I'll certainly try with 3.2.6-1 at the next boot!

I've removed most of the autogenerated information from this mail because I
don't think there's anything relevant about this problem. On the other hand,
some information which might be of use is:
* CPU: AMD Athlon II X2 260
* memory: 8GB
* disk 1: Seagate ST3500620AS
* disk 2: WD WD5001AALS

-- Package-specific info:
** Version:
Linux version 3.2.0-1-amd64 (Debian 3.2.4-1) (waldi@debian.org) (gcc version 4.6.2 (Debian 4.6.2-12) ) #1 SMP Sun Feb 5 15:17:15 UTC 2012

** Command line:
BOOT_IMAGE=Linux-3.2 ro root=/dev/mapper/vg0-root

** Model information
sys_vendor: System manufacturer
product_name: System Product Name
product_version: System Version
chassis_vendor: Chassis Manufacture
chassis_version: Chassis Version
bios_vendor: American Megatrends Inc.
bios_version: 0801   
board_vendor: ASUSTeK Computer INC.
board_name: M5A78L
board_version: Rev X.0x

** PCI devices:
00:11.0 SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391] (prog-if 01 [AHCI 1.0])
	Subsystem: ASUSTeK Computer Inc. Device [1043:8389]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 22
	Region 0: I/O ports at c000 [size=8]
	Region 1: I/O ports at b000 [size=4]
	Region 2: I/O ports at a000 [size=8]
	Region 3: I/O ports at 9000 [size=4]
	Region 4: I/O ports at 8000 [size=16]
	Region 5: Memory at fbfffc00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ahci

-- System Information:
Debian Release: 6.0.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable'), (400, 'testing'), (99, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Attachment: 27022012041-25%-gray.png
Description: PNG image

Attachment: 27022012040-25%-gray.png
Description: PNG image


Reply to: