[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#654434: [3.1.1 -> 3.1.4 regression] Kernel doesn't hibernate, instead you end up on a black screen

Hi Santiago,

Santiago Garcia Mantinan wrote:

> Looking for splash system... none
> s2disk: Snapshotting system
> then typically I see something like a mode change (screen gets black and
> then comes back with those two lines and s2disk continues to output
> messages) but when it fails the screen gets black and doesn't come back.  At
> this state you can type (computer is not frozen) and see what you type but
> pressing Ctrl+C or Ctrl+Z doesn't do anything, not even Ctrl+Alt+Del.  It
> even happens that sometimes if you wait for a while it will get out of the
> black screen and get back to where you were before trying to hibernate.
> I have uswsusp installed on all of them so I was suspecting a bad behaviour
> of it when used with recent kernels, so I uninstalled it on the lenovo and
> tested again with 3.2.0 rc7 and it failed as well.

Hm.  What steps do you use to reproduce this without uswsusp?  I guess
I would suggest first making sure this happens with

	echo disk >/sys/power/state

and then tracking down what exactly goes wrong using hints from


(e.g., using no_console_suspend and seeing if you can get any

Comparing boot + hibernate logs from an affected and an unaffected
kernel might be interesting, too.

Sorry for the trouble, and hope that helps,

> 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
> 	Subsystem: Hewlett-Packard Company Presario C700 [103c:30d9]
> 	Kernel driver in use: i915

Reply to: