On Mon, 2012-01-02 at 11:58 +0900, firstname.lastname@example.org wrote: > Thorsten Glaser: > > >It introduces a new separated file include/linux/aufs_name.h. > > > > Isn=E2=80=99t that a bit overkill? > > Hmm, I may have to agree with that. > Honestly speaking, I don't like this approach. > But embedding (expanding) AUFS_NAME is worse for me. Why, how often do you expect to change AUFS_NAME? [...] > So I still think it is better to define it in Makefile. > If I remove refering the "current" macro in the definition, then the > life will be easier, but it is still useful and I want to keep > it. Additonally it is not a essential problem I think. > Finally I'd like to add sched.h between aufs_name and pr_fmt (see the > attached patch). > How do you think? I think it would be much better to put this in fs/aufs/aufs.h and make each of fs/aufs/*.c include that first. > J. R. Okajima > > --- a/fs/aufs/Makefile > +++ b/fs/aufs/Makefile > @@ -10,6 +10,7 @@ endif > ccflags-y += -DDEBUG > # sparse doesn't allow spaces > ccflags-y += -imacros linux/aufs_name.h > +ccflags-y += -include linux/sched.h > ccflags-y += -D'pr_fmt(fmt)=AUFS_NAME"\040%s:%d:%s[%d]:\040"fmt,__func__,__LINE__,current->comm,current->pid' > > obj-$(CONFIG_AUFS_FS) += aufs.o The comment about sparse belongs immediately before the definition of pr_fmt. Ben. -- Ben Hutchings All the simple programs have been written, and all the good names taken.
Description: This is a digitally signed message part