[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#628444: linux-image-2.6.39-1-686-pae: iwlagn - "MAC is in deep sleep", cannot restore wifi operation

On Sat, 17 Sep 2011, maximilian attems wrote:

I wasn't aware that the 3.0 kernels were out until you sent this
message. Unfortunately, since this bug takes time to manifest, it
will require that I run with 3.0 as my default kernel, this means I
have to get vmware to run with it (since I use it heavily), and that
is usually a problem for bleeding edge kernels.  I will look into
it, but it may be a week or so before I can even try running a 3.0

bleeding edge would be against linux-next, 3.1-rcX is in experimental.
that would be next target if problem persists.

Bleeding edge is anything which hasn't been in use long enough that there is still significant potential for major bugs. Having had very long experience with the Linux kernel (and having fixed the bugs myself on several occasions), the 3.x kernels qualify.

Anyway according to your description you are loading binary blobs
into your OS, so you just voided our support and this bug report
can be closed away unless you can reproduce without.

1- Actually, VMWare provides the source code for their kernel interface
   code which uses loadable modules, but usually someone has to work up a
   source code patch for the latest versions of the kernel (< 6-9 months
   old) and then users have to patch and rebuild the kernel interface.  I
   have worked up patches myself on a few occasions, but I don't really
   have the time.

2- I wasn't running VMWare at the time I reported these problems, I use
   it only for customer software development and there weren't any
   customers back then.  Now I am rather busy.

So no, this bug report cannot be closed on that basis and as I stated before, even a cursory scan of the internet shows this is a common problem for people running similar hardware, so even if I were running "binary blobs", the bug should remain open.

NOTE: If one were to assume that VMWare were in any way relevant to this problem, then the bug should move from machine to machine as I migrate my development environment. Instead, the bug showed up when I moved to a new machine with different hardware and device drivers, but the same kernel.
I upgraded to a variety of different kernels in the hope that one of them
would work and have settled on the current one I am running because it seems to have the problem less often.

Shannon C. Dealy      |               DeaTech Research Inc.
dealy@deatech.com     |          - Custom Software Development -
Phone: (800) 467-5820 |          - Natural Building Instruction -
   or: (541) 929-4089 |                  www.deatech.com

Reply to: